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Carlson Point Cloud Primer 
The following is an introductory primer (tutorial) for Carlson Point Clouds. Although this primer is not a 
comprehensive tutorial (all point cloud projects pose their own unique set of challenges), the intent of this 
primer is to work through some basic procedures with a goal of creating a representative surface model (e.g. 
TIN) of the project site. If you wish to follow along with the tutorial and use the same Scan files, you can 
download them from the following DropBox file sharing URL: 
 
https://www.dropbox.com/s/gjekk0vmib6kcdz/PointCloudPrimer.zip?dl=0 

Assumptions and Notations 
The illustrations provided throughout this primer assume Carlson Point Cloud Basic version 2019 (or earlier) is 
installed (screen captures subject to change without notice). Carlson Software would like to gratefully recognize 
and thank the professionals at Allgeier, Martin and Associates, Inc, Joplin, MO, for their efforts toward the 
gathering and contribution of the data (used and shared with permission) throughout this primer. 

Getting Started 
Load the Point Cloud Menus 
Work done in Carlson's Point Cloud module is done on a per-project basis. To create a new project, you must 
first have a CAD drawing open in AutoCAD or IntelliCAD. To load the Point Cloud menu structure, load it 
through the menus by going to Settings → Carlson Menus → Point Clouds (or click on the Lightning Bolt icon 
found on the Carlson Menus tool-bar). This will display the menu structure for Point Clouds. 

Configuring Point Cloud 
Carlson Point Cloud features different cloud-processing "engines" that provide different degrees of 
functionality. For the purpose of this primer, let's verify the engine we'll be using. 

1. From the Point Clouds menu, click Point Cloud Setup: 

 
2. Specify the Point Cloud Engine as illustrated above and click OK. 

Create a Point Cloud Project 
Our next task will be to create a Point Cloud "project" that is a structured organization of the file(s) and output 
of the Point Cloud data. 

https://db.tt/3quxbAeG
https://www.dropbox.com/s/gjekk0vmib6kcdz/PointCloudPrimer.zip?dl=0
http://www.amce.com/
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1. From the Point Clouds menu, click Project Manager to display the Point Cloud 
Project Manager "docked dialog" box: 

 
2. Click the New button. 
3. Indicate the File Name as shown below and then click on Save: 

 

Your initial project should look like the following image. In the organized "tree" structure, you will see your 
Project with various defaults: 
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Point Cloud Settings 
It is often desirable to validate (or possibly change) settings used by Point Cloud. 

NOTE: Each of the items in the Point Cloud Project react to a mouse right-click. For categories of data in the 
tree-view that have [square bracket] numbers, a mouse double-click action can also be used to activate the 
entry. 

1. Let's explore and validate some general project settings. Click the Settings button. 
2. In the Units and Ranges section, set the values as shown below: 
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3. Explore the Naming Conventions section. This allows you to change the names 
associated with the various project items: 

 
4. Finally, take a look at the Viewer section and make any changes to the defaults if you desire. 
5. Once complete, click on green-check button to accept the Project Settings. 

NOTE: To accept (or commit) the results of (or to continue with) a function, you should click the "green-
check" button. If you want to cancel a process, click the "red X" button. 

Adding Data 
In most terrestrial scanning situations, a site might be scanned from several scanner positions to allow for the 
site to be seen from different angles so a true 3D representation of the site can be achieved. The reader should 
be aware that Point Cloud can handle different scanner setups, each having obtained a scan in their own scanner 
coordinate system. Included with these scans are target scans and control coordinates for the site. This allows 
the individual scans to be merged into one entity for further manipulation. 
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In this data set, however, we have been given a "processed point cloud" from an 
unmanned aerial vehicle (UAV) that can be directly modeled without further manipulation. 

Cloud Import 
1. Right click on Clouds category of the project tree. 
2. Choose Import → LIDAR. 
3. It will now display another dialog box asking you for the file that has the necessary data in it. Navigate to where 

the file resides and open the file. 
4. Based on units used to process the data, additional scaling may be desired. For this particular example, indicate 

the scaling option as shown below: 

 

NOTE: The *.LAS file should import as a Cloud component to your project tree. Depending on the processing 
capabilities of your computer, this action may take just a few seconds to several minutes to complete. 

NOTE: For the sake of brevity and consistency in this discussion, let's rename the cloud object to simply be 
Cloud-00: 

1. Right-click on the first cloud data set we imported and choose Rename. 
2. Give the cloud object a name of Cloud-00 and press the Enter key to commit the new name. 

NOTE: To get an idea of how many points were imported, right-click on the Cloud-00 entry and choose 
Properties and dismiss the dialog box when complete; your values may differ from those shown below: 
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Creating a View of the Cloud 
Now we will create a view for further manipulation. 
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1. Select Cloud-00 by either a double left-click or right-click → View and it will open a 
dialog box as seen below: 

 
2. Select the Create New option, and set the Scene name as shown. 
3. In the color panel, choose Color for the category and Direct for the type. 
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4. After clicking green-check, a new window should pop up after the scan has loaded 
that shows a scene similar to the one below: 

 

Making a "Sub" Cloud 
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Rather than processing the limits of the entire cloud that we've imported, our next 
goal will be to make another cloud that is a subset of Cloud-00. 

Isolating the Area of Interest 
The UAV has picked up some points outside our area of interest. In effort to narrow the data set, we'd like to 
limit our study to a portion of Cloud-00. 

1. From the Scene created above, click Selection → Add → Perimeter: Inside. 
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2. Identify a region similar to that shown below: 

 

Make the "Sub" Cloud 
Let's physically make the sub-cloud: 
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1. From the Scene created above, click Create → Cloud: 

 
2. Provide the name shown below and click green-check when ready: 

 

The new Cloud will be added to the Clouds group and can be acted upon like any other Cloud. 

Cleaning the Point Cloud Data 
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As a subset of Cloud-00, the new point cloud contains the same data as the original 
but only in our defined area. Inevitably, we'll probably have extraneous data (i.e. "noise") that can be removed 
that should improve the final result (that being a surface model TIN). Let's eliminate unwanted data points. 

1. Right-click on the new cloud in the Project tab and select the Clean option. This will bring up the Clean Cloud 
dialog box: 

 
2. Set the values as shown and tap Green Check when ready. 



13  
 

Carlson Software | 33 East Second Street | Maysville, Kentucky 41056 USA 
+1 606 564 5028 | www.carlsonsw.com 

"Redundant" points within the threshold value(s) are removed from the cloud and a 
new (and smaller) cloud is added to the Point Cloud tree. 

Re-sampling (Decimating) the Point Cloud Data 
In an effort to further reduce the density of the point cloud data, a common practice is to "re-sample" (or 
decimate) the data within the point cloud. 
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1. Right-click on the new cloud in the Project tab and select the Resample option. This 
will bring up the Resample dialog box: 

 
2. Specify the values shown. When ready, click Green Check to create your new "decimated" point cloud. 

NOTE: Generally, the Oc-Tree resampling method typically provides the best results but may take several 
minutes to complete. After it is complete, you will have a new "cleaner" cloud under Project → Clouds. 

Getting to "Bare Earth" (optional) 
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Depending on the application used to gather the original point cloud data, it may be 
necessary to remove vertical components (e.g. trees, builds, vehicles, utility poles, etc) from the data set so 
these types of components don't impact (or contribute to) the surface model we're attempting to create. The 
process of removing these elevated points is achieved by passing the point cloud data through a "bare earth" 
extraction algorithm. 

NOTE: Generating a bare earth data set requires a View to be active and the View must be oriented with a 
"Top" display perspective. 

1. Right-click on the new cloud in the Project tab and select the View option. This will bring up the View dialog box: 
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2. Tap Green Check to display the View and make sure the "Top" display perspective 
is current by clicking on the button illustrated below: 
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3. From the Project tree, right-click on the Cloud name and select Bare Earth by Grid: 

 

Additional Clean-up 
In certain situations, it might be necessary to further (and manually) remove points from the cloud that were not 
removed as part of the exercise(s) above. Let's explore this process now. 
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1. Right-click on the new cloud in the Project tab and select the View option. This will 
bring up the View dialog box: 

 
2. Tap Green Check to display the View and make sure a "Front" or "Side" or "Back" display perspective is current 

by clicking on a button illustrated below: 
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NOTE: This action will allow us to inspect the cloud from a "profile" (or "elevation") perspective. 

3. Our next task will be to build a selection set of points that we will eventually want to discard from the cloud. 
From the Selection menu, click Add → Window and place a small "box window" around the points you will 
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eventually want to discard (as needed) as illustrated below: 

 
4. Examine the scene from different perspectives and continue to refine the selection set via the Selection menu 

commands. As points are added into the selection set they will turn red. 
5. When your selection set of points to points to discard is complete, issue the Selection → Invert command. This 

should "activate" all of the good points and de-activate all of the points you wish to discard. 
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6. Let's now create a new cloud out of the selection set of "good" points. From the 
Create menu, click Cloud and provide the name as indicated below: 

 

Creating a TIN Surface 
Now that you have isolated, cleaned and resampled your area of interest that should also (effectively) be bare 
earth, you can make a triangulated TIN surface from your data points. 

1. Right click on the new point cloud and select Create TIN to launch the Create TIN dialog box: 

 
2. Set the values as shown and click Green Check to create the TIN. This process may take a few minutes. 
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3. Continue with the TIN creation process and name as follows: 

 

The newly created TIN can now be used (and/or viewed) in other Carlson applications and/or exported to other 
file formats including LandXML for use in other applications. 

This completes this introduction to Carlson Point Cloud. 

http://www.landxml.org/
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