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About SurvCE 

Carlson SurvCE is the first choice in data collection software with advanced, yet easy-to-use 

functionality. Carlson SurvCE combines superior functionality, ease-of-use, and sheer 

capability to make it the first choice in data collection software. Carlson SurvCE is a complete 

data collection system for Real Time (RTK) GPS and Total Stations with in-field coordinate 

geometry. It supports the widest range of popular and new release RTK GPS and 

conventional/ robotic total stations. 

Scope of this Guide 

This guide is designed to help you quickly familiarize yourself with SurvCE. For the sake of 

conciseness, only a selection of the many SurvCE functions are presented in this guide. 

For a full description of all SurvCE solutions, refer to the SurvCE v2.5 manual. 

 

About Carlson Software 

Carlson Software develops software solutions that bring the land development professional 

from concept to completion – the full cycle of a project. An independent company founded by 

Bruce Carlson in 1983, Carlson Software is well known for its comprehensive civil engineering, 

land surveying, machine control and positioning, and mining software solutions. Its dedication 

to customer service is unique in the industry. 

Carlson Technical Support 

 

Contact information for tech support for SurvCE is provided below: 

Carlson Software, Inc. 

Corporate Headquarters 

Maysville, KY, USA 

Tel (606) 564-5028 

Fax (606) 564-6422 

e-mail: support@carlsonsw.com 

 

Carlson EMEA, BV 

Corporate Headquarters 

Almere, Netherlands 

Tel: +31 36 750 1781 

www.carlsonemea.com 

e-mail: support@carlsonemea.com 

 

Customer Service, Technical Support, Repair: 

If you need assistance with your Carlson Software products, please send an e-mail to the 

address above. U.S. support hours are Monday through Friday, 8:00 A.M. to 6:00 P.M. (EST, 

GMT -5 hours). EMEA support hours are Monday through Friday, 8:00 A.M. to 6:00 P.M. (GMT 

+1). 

 

Carlson Knowledge Base: 

http://update.carlsonsw.com/kbase_main.php 
 
 
 
 
 
 
 

V1.1 31/03/2011 
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1 Register SurvCE 
The first time you start SurvCE, you will be prompted to register your license of the software. 

If you do not register, SurvCE will remain in demo mode, limiting each job file to a maximum 

of 30 points. 

 

SurvCE registration is done via the Internet at the following address: www.survce.com 

 

You will be required to enter the following information: 

• User Name 

• Company Name 

• Serial Number* 

• Email Address 

• Phone Number 

• Fax Number 

• Hardware ID#1* 

• Hardware ID#2* 

• Reason for Install 

• Registration Code* 

*: Select Equip>About SurvCE>Change Registration in SurvCE to read this information. 

After you submit this information, your change key will be displayed and emailed to the 

address that you submit. Keep this for your permanent records. You may then enter the 

manufacturer and model of your equipment. 

 

If you do not have access to the Internet, you may fax the above information to (+1) 606-

564-9525. Your registration information will be faxed back to you within 48 hours.  

After you receive your Change Key, enter it and tap OK. You can then create a new SurvCE 

job. 

http://www.survce.com/
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2 Create or Select a Job 
A job in Carlson SurvCE is made up of several file, however, the main two files are the 

coordinate file (*.crd) and the raw data file (*.rw5). To create a job: 

1. Select the File tab and menu item 1, Job. 

2. Enter the job name (e.g. “Tutorial1”). 

 

Note: Opening an existing job is performed the same way except you select a job name as 

opposed to entering one. 

 

 
 
You can leave SurvCE from the File menu with item 0, Exit. To check your SurvCE version 

select Equip from the main menu and then item 0, About SurvCE. 
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3 Define Job Settings 
By default the software will prompt for the job units upon job creation by presenting the Job 

Settings dialog. This setting is optional and can be found on the New Job tab. 

To access Job Settings after closing the dialog, select the File tab and menu item 2, Job 

Settings. 

 

 

3.1 New Job 
This tab allows you to configure how all new jobs will be created.  

3.2 System 
 

 

 

 

 

 

 

 

 

 

 

 

The System tab is where the initial job units must be specified. It also has several options for 

specifying how data will be presented to the user. 

1. Select the System tab of Job Settings if not already there. 

2. Set the job distance unit to Feet, US Feet or Meters and the Angle unit to DMS or 

GONS\Grads as required by the job. You cannot change the job distance units once a 

point has been recorded (i.e. convert it from feet to meters). 

3. Select the Projection you are using in your job with the Edit Projection List button. 

Prior to localizing in any job you must select the proper projection. It is also 

recommended to select a geoid file (see 3.2.1). 

Now you can either select a projection from the list or add a predefined projection with 

the Add Predefined button. You can also define your own projection and add datum 

transformation parameters with the Add User Defined button. 
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3.2.1 Create a Geoid File 

Select your geoid file in Equip, item 6, Localization, go to the GPS tab and select the Geoid 

File button. You might want to finish Job Settings first and then enter the geoid file in 

Localization.  

 

Geoid files are available for a number of countries. Place the geoid file (*.gsf) in the 

SurvCE\Data folder on the controller to make it ready for import. You can also use the global 

geoid model, e.g. the EGM2008 world geoid and select the proper zone for your area. Instead 

of selecting a complete geoid, it will often be more efficient to create a smaller file suited for 

your survey. This procedure is described below.  

 

Carlson X-Port and Carlson Geoid Grids are installed separately. They are both located on the 

Carlson SurvCE CD or they can be downloaded from: 

http://update.carlsonsw.com/public/CarlsonGeoidGrids.exe 

1. Install Carlson X-port (XportSetup.exe). Use the serial number listed in the back 

of your SurvCE manual (it should be listed as X-port serial # and start out like this: 

“133…”). You can also use the Data Transfer option in Carlson Survey or Carlson 

SurvCadd in lieu of Carlson X-Port. 

2. Install the Carlson Geoid Grids (CarlsonGeoidGrids.exe). Once you have finished 

installing Carlson X-port and the geoid grid files you can now create a geoid file and 

transfer it to the data collector as follows: 

1. Hook up the data collector to the computer with the 9pin or USB cable. 

2. Turn on the Explorer and launch SurvCE. 

3. On the data collector select menu item 6, Data Transfer from the File tab. 

4. Select Carlson Transfer (it should say awaiting connection). 

5. On the desktop computer, launch Carlson X-port and select menu item Data 

Transfer from the Tools menu. 

6. Select Data Transfer sub-menu item SurvCE/G2/FastSurvey… to launch the 

SurvCOM dialog. 

7. Select the Geoid button in the bottom right corner of the SurvCOM dialog. 

8. Click the select button and navigate to the directory you installed the Geoid Grids 

to. 

9. Key in the approximate Latitude and Longitude for the center of your project, the 

Grid Size and the File Name that you want store the geoid file as. Normally you 

would want to make a 150-200 km grid file or 1.5 - 2 degrees for best 

performance. 

10. Select OK to make the geoid file and copy it to the data collector. 

11. Once the transfer is complete, close X-Port and disconnect from the data collector. 

12. Close the Data Transfer dialog on the data collector and set the geoid file by 

selecting the GPS tab of Localization located as menu item 6 on the Equip tab. 

 

3.3 Format 
This tab allows you to select the viewing format of the data displayed and entered 
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in the current job. 

3.4 Options 
This tab allows you to set configuration options for the current job. 

 

3.5 Stake 
The Stake tab is where you define the precision of the stakeout values that are reported 

during stakeout and where cutsheet (a.k.a. grade sheet) files can be setup: 

1. Select the Stake tab of Job Settings. 

2. Select the desired decimal precision. 

3. Select the Cutsheets button. 

4. Tic e.g. Point Stakes and select a file (e.g. “Tutorial_Pts”). 

5. Select the Format button to configure the cutsheet to your liking. 

6. Select OK and setup remaining cutsheets if applicable. 
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4 GPS Surveying 
Prior to starting a GPS survey, make sure you have selected the correct Job Settings such as 

units, coordinate system, options, etc. Operational settings must be defined using either 

menu item 2, GPS Base or menu item 3, GPS Rover on the Equip tab. For details about a 

specific instrument, see the SurvCE V2.5 Manual. 

Menu item 2, GPS Base on the Equip tab allows the user to set the operational settings of 

the Base Station and also provides several options for starting the survey. 

Menu item 3, GPS Rover simply established the operational settings of the rover. In case of a 

VRS survey, GPS Base can be skipped. 

 

4.1 Base Setup - Unknown Autonomous Location 
This section covers how to setup the base at an unknown location with the assumption that 

the site localization will be established using the rover. 

1. Select menu item 2, GPS Base on the Equip tab. 

2. Establish the operational settings. 

3. Enter the Base Antenna Height. 

4. Select OK. 

5. At the Base Configuration dialog, select Read from GPS from the From New 

Position tab. 

6. At the Average GPS dialog, enter the Number of Samples (Epochs) to measure 

and average. 

7. Select OK to begin measuring. 

8. Select OK to close the results dialog if the results are acceptable. 

9. Enter the base reference ID if prompted. For Trimble users, this is the broadcast ID 

and should be between 0 and 31 for CMR and between 0 and 1023 for RTCM. 

10. When prompted to save the reference file, answer Yes in case you need to set the 

base at this location again, i.e. the next day. 

11. Unplug from the base station. 

At this point the base has established a position based on averaging the autonomous readings 

taken in step 6 and should be broadcasting corrections from this location. 

To setup at this location again: Use the Read from Reference File process. 

 

 

4.2 Base Setup - Published Known Location 
This section covers how to setup the base at a published known location (e.g. Government 

Control Point) with the assumption that the site is to be based on the published coordinate 

system. 

If Published Values are Latitude and Longitude: 

1. Select menu item 2, GPS Base on the Equip tab. 

2. Establish the operational settings. 
3. Enter the Base Antenna Height. 

4. Select OK. 
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5. At the Base Configuration dialog, select Enter Lat/Lon from the From New 

Position tab. 

6. At the Enter Lat/Lon dialog, enter the published latitude, longitude and ellipsoid or 

orthometric height. Note that if a geoid file was not applied in Job Settings that the 

ellipsoid height is the only option. 

7. When prompted to continue, verify the coordinates and select Yes. 

8. Enter the base reference ID if prompted. For Trimble users, this is the broadcast ID 

and should be between 0 and 31 for CMR and between 0 and 1023 for RTCM. 

9. When prompted to save the reference file, answer Yes in case you need to set the 

base at this location again and do not have the coordinates handy. 

10. Unplug from the base station. 

At this point the entered published position was sent to the receiver and the base should be 

broadcasting corrections from this location. 

 

To setup at this location again: Use the Read from Reference File process. 

 

 
 

If Published values are Grid System coordinates: 

1. Select menu item 2, GPS Base on the Equip tab. 

2. Establish the operational settings. 

3. Enter the Base Antenna Height. 

4. Select OK. 

5. At the Base Configuration dialog, select Enter Grid System Coordinates. 

6. At the Grid Coordinate dialog, enter the published coordinates and ellipsoid or 

orthometric height. Note that if a geoid file was not applied in Job Settings that the 

ellipsoid height is the only option. 

7. When prompted to continue, verify the coordinates and select Yes. 

8. Enter the base reference ID. For Trimble users, this is the broadcast ID and should be 

between 0 and 31 for CMR and between 0 and 1023 for RTCM. 

9. When prompted to save the reference file, answer Yes in case you need to set the 

base at this location again and do not have the coordinates handy. 

10. Unplug from the base station. 

At this point the entered published position was sent to the receiver and the base should be 

broadcasting corrections from this location. 

To setup at this location again: Use the Read from Reference File process. 
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4.3 Base Setup - Assumed or Local Coordinates 
This section covers how to setup the base at a location where the coordinates are either 

assumed or have been established as a local system. 

1. Select menu item 2, GPS Base on the Equip tab. 

2. Establish the operational settings. 

3. Enter the Base Antenna Height. 

4. Select OK. 

5. At the Base Configuration dialog, select Use Local Coordinates from the From 

Known Position tab. 

6. At the Local Point dialog, enter the local coordinates or select the job point. Note that 

a geoid file should be applied in Job Settings. 

7. When prompted to save a localization file, select OK. 

8. When prompted to continue, select Yes. 

9. Enter the base reference ID if prompted. For Trimble users, this is the broadcast ID 

and should be between 0 and 31 for CMR and between 0 and 1023 for RTCM. 

10. When prompted to save the reference file, answer Yes in case you need to set the 

base at this location again. 

11. Unplug from the base station. 

At this point a localization was created by pairing the entered local coordinate and a GPS 

reading from the base station. The base should now be broadcasting corrections from this 

location. 

To setup at this location again: Use the Read from Reference File process. 

 

4.4 Base Setup - Read from Reference File 
This section covers how to setup the base at a location that was previously occupied by the 

base station and the reference file was saved. 

1. Select menu item 2, GPS Base on the Equip tab. 

2. Establish the operational settings. 

3. Enter the Base Antenna Height. 

4. Select OK. 

5. At the Base Configuration dialog, select Read from File from the From Known 

Position tab. 

6. When prompted, select the previously saved reference file and select OK. 

7. When prompted to continue, select Yes. 

8. Enter the base reference ID if prompted. For Trimble users, this is the broadcast ID 

and should be between 0 and 31 for CMR and between 0 and 1023 for RTCM. 

9. Select OK when presented with the Base Setup Successful message. 

10. Unplug from the base station. 

At this point the original GPS position in the reference file was sent to the receiver and the 

base should be broadcasting corrections from this location. 
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4.5 Base Setup - Previously Surveyed Rover Point 
This section covers how to setup the base at a location that was previously surveyed by the 

rover and the GPS record exists in the raw data file. 

1. Select menu item 2, GPS Base on the Equip tab. 

2. Establish the operational settings. 

3. Enter the Base Antenna Height. 

4. Select OK. 

5. At the Base Configuration dialog, select Previously Surveyed Point from the 

From Known Position tab. 

6. When prompted, select the Surveyed Point and select OK. 

7. When prompted to continue, select Yes. 

8. Enter the base reference ID if prompted. For Trimble users, this is the broadcast ID 

and should be between 0 and 31 for CMR and between 0 and 1023 for RTCM. 

9. When prompted to save the reference file, answer Yes in case you need to set the 

base at this location again and don't have the raw data file. 

10. Unplug from the base station. 

At this point the original GPS position was sent to the receiver and the base should be 

broadcasting corrections from this location. 

To setup at this location again: Use this method or the Read from Reference File process if 

you no longer have the raw data file. 

 

 

4.6 Rover Setup 
Select menu item 3, GPS Rover simply established the operational settings of the rover. 

Tip: 

Check that you have a fixed position before leaving the base station by selecting menu item 

7, Monitor/SkyPlot. If you are autonomous, you are not getting base correction and likely 

have issues with the radio settings. 

 

4.6.1 Current 

Select the manufacturer and model of your GPS system. You can also save your rover settings 

in a configuration file and re-load them when necessary. 
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Tip:  

You can select “GPS Simulation” as manufacturer which will bring you in a simulation mode so 

you can practice with storing points and stake out without having an instrument connected. 

 

4.6.2 Comms 

Select how the controller is connected to your GPS rover, either by cable or Bluetooth.  

When you select Bluetooth as type, clicking the tools icon next to the right of Device 

proceeds to the Bluetooth Manager screen. This screen gives you the option to choose 

which GPS receiver you would like to connect to via Bluetooth. If you click Cancel, no 

Bluetooth connection will be established. Select a receiver and click the Bluetooth icon at the 

top of the screen to connect. 

 

 

4.6.3 Receiver 

In this tab make the following settings: 

1. Select the antenna type of your GPS rover. Often the antenna type is already set by 

SurvCE, but it is important to set the correct antenna type because of the antenna 

offset. 

2. Select the antenna height. This is the pole height which you are using, SurvCE will 

automatically add the offset value to the phase center of the antenna. When the rover 

is on a pole, the antenna height is “Vertical”. When the rover is on a tripod, the 

antenna height is “Slant”.  

Example: if you have a Carlson Surveyor+ GPS rover on a 2m pole then just 

enter 2m as the antenna height. You will notice that SurvCE will correct this to 

2.0855m. The 0.0855 correction is the offset from the bottom of the receiver 

(top of the pole) to the antenna phase center which is the actual reference 

point for the GPS readings. 

The American National Geodetic Survey (NGS) has calibrated most commercially 

available GPS antenna‟s. By selecting the NGS tic box you can use the NGS 

calibration. This will have an effect on the antenna offset. 

3. Select the elevation mask. This specifies the cutoff vertical angle above the horizon. 

Any satellites below this angle will be left out of calculations. A suitable value is “13” 

or “15” degrees. 

4. Select the position rate. For surveying applications 1 Hz is an appropriate value. In 

case of accurate stake out applications 2 Hz or 5 Hz is a useful rate (if your receiver 

allows this). 

5. Store Vectors in Raw data is an option which is useful when you want export the 

GPS vectors (the GPS observation) to an office package for least squares adjustment. 

4.6.4 RTK 

Use this tab to connect to a base station or GPS RTK (VRS) network. 
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1. Select the modem Device which you will use to connect to the base or network. In 

case of a base – rover setup this will usually be a radio, in case of a network this will 

be a GSM (GPRS) modem. When you are using a GSM modem integrated in the data 

collector (e.g. the Surveyor+) then select “Data Collector Internet”. You can select the 

configure button to the right to configure the modem. You only have to do this when 

you select a new modem. In case of a connection by GPRS (e.g. for “NTRIP”, see 

below) you must enter the GPRS provider settings here: APN Server, userid and 

password. 

2. In case you connect to a GPS RTK network you select the Network type. These are 

the main options: 

 “TCP/IP Direct”: For connecting to a single modem at a base or to a VRS 

network or another network that doesn‟t require a special login. 

 “UDP/IP Direct”: This works exactly like the TCP Direct option but uses UDP 

protocol instead of TCP. Most networks use TCP. 

 

 “NTRIP”: This option is for networks that support NTRIP protocol. Pressing the 

Configure button shows the NTRIP Broadcasters that have been previously 

connected to. In order to access a network by NTRIP you need the network‟s 

IP address and port, and a userid and password. When you are connected to a 

NTRIP caster you can select a mountpoint. SurvCE will read the settings from 

the source table so you don‟t have to enter the mountpoint parameters 

yourself. 

 “Direct dial”: This will create a GSM data connection. If you select this option 

you must enter the phone number by selecting the configure icon to the right 

of Base ID at the bottom of the screen.  

 

4.7 Logging Raw Data 
Logging raw data is required if you want to post-process your raw GPS observations with p-p 

office software such as Carlson‟s SurvGNSS. This can be useful as a backup method for RTK 

and also for performing sub-centimeter geodetic surveys.  

 

You can log raw data in two basic ways: you can use the static mode option on your GNSS 

receiver (i.e. use a button combination on you receiver panel to commence the logging – see 

your Receiver Operation‟s Manual) or you can use the log raw data function in SurvCE. Note 

that this option is SurvCE is not available for all receiver brands. 

 

Using SurCE: the Survey>Log Raw GPS function allows you to fully control raw data 

logging. Using this method offers three advantages:. 

1. Antenna reduction is automatically performed during post-processing because of the 

antenna height value (from the receiver properties) stored in the raw data files. 
2. Ability to name the raw data file and insert time tags. 

3. Ability to pause/resume data logging. 
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By default, raw data is logged to the receiver‟s internal memory.  

 

 
 

To start logging: 

1. Tap Survey>Log Raw GPS. 

2. Tap Start/Resume File. 

3. Set the following parameters: 

 Elevation Mask in degrees. 

 Check the antenna height value. If it‟s wrong, tap the Change Antenna button to 

set the new value. 

 Logging interval in seconds. 

 

Confirm to start data logging. From the screen then displayed, you can do the following: 

 Name the raw data file, mark a particular point or event (Tag New Site). 

 Stop data logging (Close File). 

 Access the File Manager window in read-only mode (File Manager). 

 Continue Logging / Pause Logging. Pausing data logging means closing the 

currently open file. Continuing data logging means opening a new file. Data 

logging will start immediately based on the parameters set for the previous file. 

 

Data can be downloaded from the receiver to your PC for further processing, see your 

Receiver Operation‟s Manual for details. 
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5 Localization 
Localization is a process that allows the user to shift the GPS measurements to a local 

coordinate system. Localization can be used to improve the local fit of your national 

coordinate system (so that your survey fits in with the local situation), or to create a complete 

arbitrary coordinate system (with new origin and axes). 

To adjust to local control: 

1. Select menu item 3, Configure Rover on the Equip tab and establish the operational 

settings of the rover. 

2. Check that you have a fixed position by selecting menu item 7, Monitor/SkyPlot. If 

you are autonomous, you are not getting corrections and likely have issues with the 

radio or GSM/GPRS settings. 

 
 

3. Select menu item 6, Localization on the Equip tab and select the Points tab. 

4. Select the Add button. 

5. Enter the local coordinates or select a local point from the job. Note that you cannot 

enter a point ID if the point does not exist in the current job (go to the File tab of the 

main menu and select item 3, Points to enter local points). 

6. Select Read from GPS when prompted for the GPS Coordinates. 

7. At the Average GPS dialog, enter the Number of Samples (Epochs) to measure 

and average. 

8. Select OK to begin measuring. 

9. At the Average Results dialog, select OK if all samples were OK. If not, cancel and 

measure again. 

10. To add more than one point, repeat steps 1 through 9. 

11. Select OK to save the localization file. 

If the scale factor is 1.0 in Job Settings, then the coordinates will be Grid coordinates. If a 

value is entered, the vector distance from the first point in the localization file to the current 

position will be divided by the entered value. 

If the localization determines a scale factor because more than one point is held horizontally, 

then the scale factor in Job Settings is grayed out and reflects the local to grid factor. 

 

5.1 Store Data with Store Points 
The routine used for collecting survey data using GPS is found on the Survey tab of the main 

menu, item 1, Store Points. 
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5.1.1 Recording Data 

 
 

The graphic view of Store Points is shown below. Alternately, the user can select the Text 

option (Alt+Y) from the „helmet‟ drop down menu in the top left of the screen. 
 

On the left side of the screen you will find the zoom icons, from top to bottom: 

 Zoom Extents: This zooms the entire 

drawing to fit the screen. 

Zoom In: Zooms in 25%. 

 

Zoom Out: Zooms out 25% 

 

Zoom Window: Zooms into a 

rectangular area that you pick on the 

map screen. 

Zoom Previous: Zooms to the previous 

view. SurvCE remembers up to 50 views. 

View Options: Displays the View Options dialog box, where you can 

control aspects of points such as the symbol, the style of the plot and the freezing or 

thawing of attributes such as descriptions and elevations. To avoid “point clutter”, you can 

even set it to show only the last stored point along with setup and BS. 
 

On the right side of the screen find these options: 

 

This icon will Store a point. This function is 

also performed via 

the Enter key. (ALT-S). 

This icon will lead to a dialog where the user 

can Average up to 

999 epochs of GPS readings (ALT-A). 

This icon leads to Offset reading screens with 

options for keyed-in offsets as well as offsets taken 

by laser and hydrographic devices 

that measure distance only, or distance and 

azimuth (ALT-O). 

This icon will take you to the Configure dialog, also found on the Equip tab. Here you set 

many preferences in SurvCE such as the number of readings to average, function of the Store 
icon, and whether to display the Hgt/Desc prompt on Save (ALT-C). 
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This icon will take you to Monitor/Skyplot, also found on the Equip tab. 

 

Tips: 

1. The Enter button can be used to Read and Store. 

2. To enter the description after the reading, turn on the Hgt/Desc Prompt on Save 

option using the Configure icon or by selecting menu item 4, Configure Reading 

from the File tab. 

3. All off-center readings are accessed through the Offset icon. 

4. To change the behavior of the Enter key, select the Configure icon. 

5. To change the number of epochs that Enter and ALT-S will read, select Configure and 

change the Number of Readings to Average option. 

6. To only view linework and the last measured point, select the View Options icon or 

ALT-F. 

7. To draw linework you must have fieldcodes established in the item 5, Feature Code 

List found on the File tab of the main menu. 

 

5.2 Stakeout Points 
The routine used for staking out pre-calculated points is called Stake Points and is found on 

the Survey tab of the main menu. 

 

 

5.2.1 Defining the Point to Stake 

In order to stake a pre-calculated location you must enter the point ID or coordinates into the 

dialog that is presented when you enter Stake Points. 

1. Enter the Stakeout Point ID. 

2. Select OK to Stake the Point. 

 

 
 

Tips: 

1. Point by Direction can be used to quickly enter an offset location from the stake Point 
ID. 
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2. Math functions can be performed in the direction input boxes to solve inverses, etc... 

(e.g. 1,2 in the azimuth field would return the azimuth between points 1 and 2). Math 

functions can also be used to quickly calculate distances in the distance input boxes 

(e.g. 1,2/2 would return 1/2 the distance between points 1 and 2). 

3. Multiple points can be selected using the List icon to the right of the Point ID input box 

or by entering them separated by commas. 

4. The Add to List button will add all points entered into the Point ID input box to the 

Stakeout Point List. 

 

5.2.2 Staking Out the Point 

The graphic view of Stake Points is shown below. Alternately, the user can select the TEXT 

button to use a non-graphical interface to stakeout the point. 

 

On the left side of the screen you will find the zoom icons, from top to bottom: 

 Zoom Extents: This zooms the entire 

drawing to fit the screen. 

Zoom In: Zooms in 25%. 

 

Zoom Out: Zooms out 25% 

 

Zoom Window: Zooms into a 

rectangular area that you pick on the 

map screen. 

Zoom Previous: Zooms to the previous 

view. SurvCE remembers up to 50 views. 

View Options: Displays the View Options dialog box, where you can 

control aspects of points such as the symbol, the style of the plot and the freezing or 

thawing of attributes such as descriptions and elevations. To avoid “point clutter”, you can 

even set it to show only the last stored point along with setup and BS. 
 

On the right side of the screen find these options:  

 

 
Store 
 
 
Next (point) 
 
 
Modify 
 
 
Configure 
 
 
Monitor Skyplot 

 
 
 

Tips: 
1. Use M for Modify to enter or adjust the stake location. 

2. Use N for Next to advance to the next point ID. 

3. To change the behavior of the Enter key, select the C for Configure icon. 

4. To change the number of epochs that Enter and S will read, select C for Configure and 
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change the Number of Readings to Average option. 

5. To only view linework and the last measured point, select the View Options icon or ALT-F. 

6. To change the method that the navigation information is reported, select C for Configure 

and then the Reference tab. This is where the stakeout perspective can be changed from rod 

to instrument for example. 
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6 Feature Coding 
Carlson SurvCE has the ability to draw lines live in the field based on the feature codes 

established in menu item 5, Feature Code List on the File tab. Each code can be defined as a 

point or a 2D or 3D line (polyline). In addition to the feature code, additional Special Codes 

can be used to specify how the line is to be drawn. 

Feature codes can include one or more attributes for e.g. for GIS applications. 

Feature codes and attributes can be stored in a feature code list file (*.fcl). 

 

 

6.1 Create a Feature Code 
To create a code: 

1. Select the Add button from the Code List dialog. 

2. Specify the short Code, layer for the line, full text for the list and whether or not the 

line is 2D or 3D. Note that the layer and 2D/3D options do not apply if the code is not 

a line (polyline). 

3. Select OK to save the code to the library. 

Note: The New Features button is where all GIS style prompting is defined per code. 

 

 

6.2 User Define the Special Codes 
To modify the Special Codes so that the line drawing commands fit your current codes: 

1. Select the Special Codes button from the Code List dialog. 

2. Select the Action that requires a different Code. 

3. Enter the Code into the Code input box and select the Accept button. 
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6.3 Carlson Line Coding Entry 
Carlson SurvCE only requires a line code to be defined once and allows suffix numbers to 

determine what points get linked together. Example, code TC can be entered as TC1 or TC2 

and so on. All TC1's will linked together and the TC2's will be a separate line. Carlson SurvCE 

also allows the user to start and stop lines at any time which allows the user to re-use any 

line code after it has been ended. 

Tips: 

1. All codes are entered into the description field. 

2. All codes, including special codes, are separated by a space (e.g. TC PC). 

3. All codes allow the use of numeric suffixes. Example, code TC can be used multiple 

times simultaneously by add a numeric suffix to the end (e.g. TC or TC1 or TC2). This 

comes in handy when cross-sectioning a road. 

4. Multiple lines can be coded at a single point by simply entering the codes as 

FeatureCode space SpecialCode space FeatureCode space SpecialCode and so on (e.g. 

TC1 -7 EP1 +7). 

 

6.4 Field-to-Finish 
Carlson SurvCE has the Carlson Field-to-Finish line drawing routine for updating and 

reprocessing line codes that were entered in the description field. If the user makes an coding 

error, they can simply correct the description in the List Points dialog and run Field-to-Finish 

to correct the line work. 

To redraw the lines and update the drawing: 

1. Select the MAP button from the main menu (globe icon on the top right of the screen) 

or, if currently in a measurement screen, select ALT-M. 

2. Select Field-to-Finish from the Tools menu. 

3. Press Enter when the command line prompt shows Fld2Fin - 

Update/Select/reView/<Redraw> 

Tips: 

1. While in a measurement screen, ALT-P will take you to the points list for editing the 
descriptions. 
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2. If only the description its edited, the raw data file description will also be corrected to 

ensure raw data processing will reflect your coding corrections. 
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